Update-Probleme

Support für Extensions für phpBB 3.1.x von Entwickler OXPUS
Benutzeravatar
oxpus
Chief handy-man
Beiträge: 2414
Registriert: Do 13. Dez 2007, 23:06
Wohnort: Irgendwo im I-Net
Kontaktdaten:

Re: Update-Probleme

Beitrag von oxpus » Mi 21. Jan 2015, 10:50

Wie lautet beispielsweise einer der Links?
Karsten Ude

Kein Support zu unaufgeforderten PN's, Email oder via Messenger!

Holger
Beiträge: 85
Registriert: Di 25. Mär 2008, 09:17

Re: Update-Probleme

Beitrag von Holger » Mi 21. Jan 2015, 10:53


Benutzeravatar
oxpus
Chief handy-man
Beiträge: 2414
Registriert: Do 13. Dez 2007, 23:06
Wohnort: Irgendwo im I-Net
Kontaktdaten:

Re: Update-Probleme

Beitrag von oxpus » Mi 21. Jan 2015, 13:36

Hm, vielleicht ein kleiner Dreher drinnen.
Es sollte schon die Detaillierte aufgehen.
Prüfe ich heute Abend.
Karsten Ude

Kein Support zu unaufgeforderten PN's, Email oder via Messenger!

Benutzeravatar
oxpus
Chief handy-man
Beiträge: 2414
Registriert: Do 13. Dez 2007, 23:06
Wohnort: Irgendwo im I-Net
Kontaktdaten:

Re: Update-Probleme

Beitrag von oxpus » Mi 21. Jan 2015, 22:07

So, Fehler gefunden.
Bitte die Extension noch einmal herunterladen und zumindest die Datei /ext/oxpus/dl_ext/includes/modules/dl_modcp.php ersetzen.
Dann ist der korrekte Link enthalten.
Karsten Ude

Kein Support zu unaufgeforderten PN's, Email oder via Messenger!

Holger
Beiträge: 85
Registriert: Di 25. Mär 2008, 09:17

Re: Update-Probleme

Beitrag von Holger » Do 22. Jan 2015, 10:01

Sehr gut! Danke!

JoachimHolzbrenner
Beiträge: 5
Registriert: Di 14. Feb 2017, 15:56

Re: Update-Probleme

Beitrag von JoachimHolzbrenner » Di 14. Feb 2017, 17:31

oxpus hat geschrieben:
Di 20. Jan 2015, 21:45
Holger hat geschrieben:Can't find FULLTEXT index matching the column list [1191]
Schau mal bitte in die erweiterte Beschreibung zur Extension hier im Download Bereich.
Dort ist die Lösung enthalten.
Ich habe genau das selbe Problem :(

Ich bin ebenfalls so vorgegangen:
- zunächst das Forum selbst einem Update unterzogen
- danach die Download-Extension installiert,
- dann die zuvor gesicherten Tabellen (alle mit _dl und _downloads) wieder zurück in die Datenbank geschrieben
- danach das SQL-Statement welches die Version auf 7.0.0 setzt ausgeführt
- dann den Foren-Cache gelöscht
- dann die Extension deaktiviert und anschließend wieder aktiviert

Die Downloads (also die Dateien) habe ich an die korrekte Stelle im Filesystem geschoben und bekomme auch alle Einträge richtig im Download-Portal angezeigt.

Aber wenn ich eine Datei herunterladen möchte, erhalte ich Fehlermeldungen der gleichen Art wie oben - also "Can't find FULLTEXT index ..."

Leider weiß ich nicht welche "erweiterte Beschreibung" gemeint ist und wo ich diese finden kann :?

Benutzeravatar
oxpus
Chief handy-man
Beiträge: 2414
Registriert: Do 13. Dez 2007, 23:06
Wohnort: Irgendwo im I-Net
Kontaktdaten:

Re: Update-Probleme

Beitrag von oxpus » Di 14. Feb 2017, 19:33

Leider weiß ich nicht welche "erweiterte Beschreibung" gemeint ist und wo ich diese finden kann
In der Beschreibung zum Download hier im Download Bereich.

Noch mal zusammengefasst:
Du musst entweder im ACP die Option für ähnliche Downloads abschalten (ACP > Erweiterungen > Download Bereich > Allgemeine Einstellungen > Auswahl "Anzeigen" (rechts oben) > Option "Anzahl ähnlicher Downloads:" auf 0 stellen) oder diese SQL-Anweisungen in der Datenbank (z. B. mit phpmyadmin) ausführen:

Code: Alles auswählen

ALTER TABLE phpbb_downloads ENGINE = MyISAM;
ALTER TABLE phpbb_downloads CHANGE COLUMN description description MEDIUMTEXT NOT NULL;
ALTER TABLE phpbb_downloads ADD FULLTEXT INDEX desc_search(description);
Karsten Ude

Kein Support zu unaufgeforderten PN's, Email oder via Messenger!

JoachimHolzbrenner
Beiträge: 5
Registriert: Di 14. Feb 2017, 15:56

Re: Update-Probleme

Beitrag von JoachimHolzbrenner » Di 14. Feb 2017, 20:09

Vielen Dank!
Die ALTER-Queries haben das Problem gelöst.

Aber noch ein Hinweis:
Aus irgendeinem Grund habe ich die Option "Anzahl ähnlicher Downloads" weder unter "Anzeigen" noch unter einem anderen Punkt.
Anbei ein Screenshot.
dl_screen.png
dl_screen.png (89.76 KiB) 934 mal betrachtet
Kann es sein, dass sich die Extension noch nicht aktualisiert hat?
Im Footer und unter ACP > Erweiterungen > Downloadbereich > Übersicht steht, dass es Version 7.0.0 ist - weil ich das vor De- und Reaktivierung so in die DB eingetragen habe - aber unter ACP > Anpassen > Erweiterungs-Verwaltung > Erweiterungen verwalten steht, dass es Version 7.2.2 ist.

Benutzeravatar
oxpus
Chief handy-man
Beiträge: 2414
Registriert: Do 13. Dez 2007, 23:06
Wohnort: Irgendwo im I-Net
Kontaktdaten:

Re: Update-Probleme

Beitrag von oxpus » Di 14. Feb 2017, 21:40

Die Übersicht der Extensions zeigt die Versionsnummer, die in einer Datei gespeichert ist.
Das hat nicht immer etwas mit der Aktualität der Datenbank-Version zu tun.
Bitte die Extension noch mal deaktivieren und neu aktivieren.
Die Version, die in der Extension angezeigt wird, ist nämlich die korrekte Version.
Ausser, der Forum-Cache wäre nicht aktuell, daher erst mal bitte diesen aktualisieren.

Und zu der Option:
Die müsste genau in diesem Screenshot vorhanden sein.
Allerdings ist es auch denkbar, dass die Option noch deaktiviert bleibt, weil der Forum-Cache noch veraltet ist.
Zumindest ist der Fehler weg, weil die Datenbank jetzt korrekt aufbereitet ist.
Karsten Ude

Kein Support zu unaufgeforderten PN's, Email oder via Messenger!

JoachimHolzbrenner
Beiträge: 5
Registriert: Di 14. Feb 2017, 15:56

Re: Update-Probleme

Beitrag von JoachimHolzbrenner » Di 14. Feb 2017, 21:48

Ok, ich hab den Cache jetzt sowohl vor als auch nach dem Deaktivieren noch mal gelöscht, bevor ich die Extension wieder aktiviert habe.
Jetzt wird auch die Option korrekt angezeigt.

Vielen Dank noch mal für deine Hilfe!

Antworten