Tabproblem

Rund um phpBB3.oxpus.net, auch gerne Offtopic
Gesperrt
Die Mathematik

Tabproblem

Beitrag von Die Mathematik » Di 4. Okt 2011, 16:51

Hallo,

ich habe nach dem folgenden Schema Tabs in meinem Forum oben Links aufgebaut:

Code: Alles auswählen

<div id="tabs">
       <ul>
          <li<!-- IF SCRIPT_NAME == 'index' or SCRIPT_NAME == 'viewforum' or SCRIPT_NAME == 'viewtopic' --> class="activetab"<!-- ENDIF -->><a href="{U_INDEX}"><span>{L_INDEX}</span></a></li>
          <!-- IF S_DISPLAY_SEARCH --><li<!-- IF SCRIPT_NAME == 'search' --> class="activetab"<!-- ENDIF -->><a href="{U_SEARCH}" title="{L_SEARCH_ADV_EXPLAIN}"><span>{L_SEARCH}</span></a></li><!-- ENDIF -->
          <!-- IF S_DISPLAY_MEMBERLIST --><li<!-- IF SCRIPT_NAME == 'memberlist' --> class="activetab"<!-- ENDIF -->><a href="{U_MEMBERLIST}" title="{L_MEMBERLIST_EXPLAIN}"><span>{L_MEMBERLIST}</span></a></li><!-- ENDIF -->
          <li<!-- IF SCRIPT_NAME == 'faq' --> class="activetab"<!-- ENDIF -->><a href="{U_FAQ}" title="{L_FAQ_EXPLAIN}"><span>{L_FAQ}</span></a></li>
		  <li<!-- IF SCRIPT_NAME == 'geomap' --> class="activetab"<!-- ENDIF -->><a href="{U_GEOMAP}" title="{L_GEOMAP}"><span>{L_GEOMAP}</span></a></li>
		  <li<!-- IF SCRIPT_NAME == 'newspage' --> class="activetab"<!-- ENDIF -->><a href="{U_NEWS}" title="{L_NEWS}"><span>{L_NEWS}</span></a></li>
		  <li<!-- IF SCRIPT_NAME == 'points' --> class="activetab"<!-- ENDIF -->><a href="{U_POINTS}" title="{L_POINTS}"><span>{L_POINTS}</span></a></li>
		  <li<!-- IF SCRIPT_NAME == 'shop' --> class="activetab"<!-- ENDIF -->><a href="{U_SHOP}" title="{L_SHOP}"><span>{L_SHOP}</span></a></li>
		  <li<!-- IF SCRIPT_NAME == 'stats' --> class="activetab"<!-- ENDIF -->><a href="{U_STATS}" title="{L_STATS}"><span>{L_STATISTICS}</span></a></li>
		  <li<!-- IF SCRIPT_PATH == 'gallery/index.php' --> class="activetab"<!-- ENDIF -->><a href="{U_GALLERY_MOD}" title="{L_GALLERY}"><span>{L_GALLERY}</span></a></li>
		  <li<!-- IF SCRIPT_NAME == 'downloads.php' --> class="activetab"<!-- ENDIF -->><a href="{U_DOWNLOADS}" title="{L_DOWNLOADS}"><span>{L_DOWNLOADS}</span></a></li>
		  <li<!-- IF SCRIPT_NAME == 'tracker' --> class="activetab"<!-- ENDIF -->><a href="{U_TRACKER}" title="{L_TRACKER}"><span>{L_TRACKER}</span></a></li>
       </ul>
</div>
Das hat bisher immer wunderbar funktioniert, doch, wenn ich auf Downloads klicke rührt sich überhaupt nichts, dann bleibt er auf der Seite. Mit allen anderen Tabs geht das wunderbar. Mein Forum: http://legmbhkeg.square7.ch/forum

Weiß jemand was da falsch ist und wie man das verbessern kann?

Gruß
Die Mathematik

Benutzeravatar
WileCoyote
Beiträge: 108
Registriert: Mo 22. Nov 2010, 14:55
Kontaktdaten:

Re: Tabproblem

Beitrag von WileCoyote » Di 4. Okt 2011, 19:36

Ersetze

Code: Alles auswählen

        <li<!-- IF SCRIPT_NAME == 'downloads.php' --> class="activetab"<!-- ENDIF -->><a href="{U_DOWNLOADS}" title="{L_DOWNLOADS}"><span>{L_DOWNLOADS}</span></a></li>
durch

Code: Alles auswählen

        <li<!-- IF SCRIPT_NAME == 'downloads.php' --> class="activetab"<!-- ENDIF -->><a href="{U_DL_NAVS}" title="{L_DOWNLOADS}"><span>{L_DOWNLOADS}</span></a></li>
lg,
WileCoyote
______________________________________________________________________________________________
Ein kleine Sammlung an deutschen Übersetzung für verschiedene phpBB MODs findet ihr unter wu-systems.at

Die Mathematik

Re: Tabproblem

Beitrag von Die Mathematik » Mi 5. Okt 2011, 07:12

Dankeschön es hat funktioniert. Als ich ihn anklicken wollte kam es auch, er war nur leider nicht als aktiver Tab zu erkennen. Das .php bei downloads.php war in dem Falle überflüssig weil der Befehl "<!-- IF SCRIPT_NAME ==" bereits festlegt, dass es eine php-Datei ist. Jetzt funktioniert es mit dem folgenden Text:

Code: Alles auswählen

<li<!-- IF SCRIPT_NAME == 'downloads' --> class="activetab"<!-- ENDIF -->><a href="{U_DL_NAVS}" title="{L_DOWNLOADS}"><span>{L_DOWNLOADS}</span></a></li>
Danke für deine Hilfe. :ugeek:

Benutzeravatar
oxpus
Chief handy-man
Beiträge: 2398
Registriert: Do 13. Dez 2007, 23:06
Wohnort: Irgendwo im I-Net
Kontaktdaten:

Re: Tabproblem

Beitrag von oxpus » Mi 5. Okt 2011, 13:48

Dieses Forum ist nicht dazu gedacht, Änderungen am eigenen Forum zu besprechen, bzw. allgemeinen Support zu leisten.
Ich schliesse dieses Thema daher an dieser Stelle ab und verschiebe es in ein passenderes Forum.
Karsten Ude

Kein Support zu unaufgeforderten PN's, Email oder via Messenger!

Gesperrt