Vollbild eines Downloadvorschaubildes wird nicht mehr angezeigt.

Support für Extensions für phpBB 3.2.x von Entwickler OXPUS
Antworten
MDuss
Beiträge: 92
Registriert: So 30. Dez 2012, 10:26

Vollbild eines Downloadvorschaubildes wird nicht mehr angezeigt.

Beitrag von MDuss » So 14. Mai 2017, 12:51

Hi.

Aktuell habe ich folgendes Problem.
Wenn ich einem Download ein Bild beifüge, dann erscheint beim klicken auf das Thumb nicht mehr das Vollbild.
Bis Version 7.2.3 hat es noch funktioniert.

Jetzt in Version 7.2.5 geht es wohl nicht mehr. Ist das so gewollt, oder funktioniert da etwas anderes nicht ganz richtig?

MfG
MDuss

Benutzeravatar
oxpus
Chief handy-man
Beiträge: 2391
Registriert: Do 13. Dez 2007, 23:06
Wohnort: Irgendwo im I-Net
Kontaktdaten:

Re: Vollbild eines Downloadvorschaubildes wird nicht mehr angezeigt.

Beitrag von oxpus » So 14. Mai 2017, 13:19

Da du an anderer Stelle schon Probleme mit der Hilfefunktion der Extension hast und beides über Javascript aufgerufen wird, solltest du mal deinen Browser Cache leeren.
Vielleicht hilft das schon.
Karsten Ude

Kein Support zu unaufgeforderten PN's, Email oder via Messenger!

MDuss
Beiträge: 92
Registriert: So 30. Dez 2012, 10:26

Re: Vollbild eines Downloadvorschaubildes wird nicht mehr angezeigt.

Beitrag von MDuss » So 14. Mai 2017, 14:00

Hi oxpus.

Habe mal den Browsercache gelöscht und auch Java deinstalliert und neu installiert.
Aber das hat auf die Bilder neu einen kleinen Effekt gehabt.
Wenn ich jetzt mit dem Mauszeiger auf ein Vorschaubild zeige, dann wird über dem Vorschaubild unterhalb des Mauszeigers ein Textfenster angezeigt mit dem Downloadtitel.
Aber wenn ich auf das Vorschaubild klicke, dann erscheint das Vollbild nach wie vor nicht.

Da gibt es leider keine Besserung.

Ich habe das ganze mit dem Vorschaubild allerdings auch immer über einen kleinen Umweg gemacht.

Da ja die Vorschaubilder immer im Ordner "thumbs" gespeichert werden, und damit das ganze bei der Menge an Bilder unübersichtlich wird, habe ich im Ordner "thumbs" weitere Ordner mit dem Spieletitel als Ordnername erstellt.
Also gibt es z.B. im Ordner "thumbs" jetzt auch Order mit dem Namens "Spiel 1", "Spiel 2" ..., wo dann auch die Bilder enthalten sind.
Danach habe ich in der SQL Datenbank von Hand in der Tabelle "phpbb_downloads" im Feld "thumbnail" den zusätzlichen Ordner samt Bild angegeben.
Also im obigen Beispiel hätte ich dann in dem Feld thumbnail eingetragen:
Spiel 1/Beispiel 1.jpg

Wobei Beispiel 1.jpg das Vollbild ist.

Im Forum selbst wurde dann das Bild verkleinert angezeigt, so wie es jetzt aktuell ist.
Sobald ich dann auf das Bild draufklicke ist ein Fenster aufgegangen bzw. es wurde in dem aktuellen Tab Überblendet, oder wie auch immer man das genau nennt, keine Ahnung, mit dem eigentlichen Vollbild.

Noch ein kleiner Hinweis. Wenn ich die Bilder in die Datenbank eingetragen habe, dann habe ich die Leerzeichen so gelassen und nicht durch %20 ersetzt. Das war zumindest bisher noch nie nötig gewesen. Also Spiel 1/Beispiel 1.jpg ist so geblieben, ich habe in der SQL Datenbank kein Spiel%201/Beispiel%201.jpg daraus gemacht.

Bis Version 7.2.3 hatte es auch ohne Probleme funktioniert.
Aber jetzt, nachdem ich auf Version 7.2.5 gegangen bin, geht es halt nicht mehr.

MfG
MDuss

Ich schicke dir mal per PM einen Link zu einem Eintrag in der Datenbank und einen Link zu dem Vollbild.
Mal sehen, ob es bei dir funktioniert, und dann das Problem nur bei mir liegt, oder ob es bei dir auch nicht geht.

Benutzeravatar
oxpus
Chief handy-man
Beiträge: 2391
Registriert: Do 13. Dez 2007, 23:06
Wohnort: Irgendwo im I-Net
Kontaktdaten:

Re: Vollbild eines Downloadvorschaubildes wird nicht mehr angezeigt.

Beitrag von oxpus » So 14. Mai 2017, 14:21

Ähm, die Bilder werden nach wie vor über die gleiche Funktion aufgerufen, wie noch in 7.2.3.
Daran hat sich nichts geändert.
Es muss irgendwas mit den Cache in deinem Forum oder Browser zu tun haben.

Und noch mal: Das hat nichts mit Java zu tun.
Die Funktionen werden per Javascript ausgelöst.
Javascript ist nicht Java ;-)

Hast du vielleicht auch die Lightbox Extension installiert?
Darüber hatte ich immer wieder mal von Problemen gelesen.
Karsten Ude

Kein Support zu unaufgeforderten PN's, Email oder via Messenger!

MDuss
Beiträge: 92
Registriert: So 30. Dez 2012, 10:26

Re: Vollbild eines Downloadvorschaubildes wird nicht mehr angezeigt.

Beitrag von MDuss » So 14. Mai 2017, 14:52

Hi oxpus.

Das mit dem Javascript habe ich gerade auch festgestellt, als ich mal nachsehen wollte, wo man diese Funktion ein bzw. aus schalten kann.
Nun, was soll ich sagen, diese Funktion ist auf jeden Fall aktiviert.

Die Lightbox Extension habe ich nicht installiert, und war auch noch nie installiert.

Also ich habe es bei mir mal mit zwei Browsern Probiert, dem IE11 und dem Firefox 53.0.2
Bei beiden geht es nicht.
Die Browser Caches habe ich gelöscht, und auch den Forumscache, als auch den Cache innerhalb deiner Extension.
Auch die CHMOD Berechtigung habe ich nochmals geprüft, die sind für die Cache Ordner alle OK.

Habe auch mal meine VM angeschmissen und dort unter einer XP Installation mit 3 Browsern getestet (IE 8, Opera 36.0 und Firefox 40.0.2). Das war auch kein Erfolg.
Also quasi 2 PCs, mit unterschiedlichen Browsern. Könnte eventuell doch eine Datei der Extension aus versehen verändert worden sein, welche nicht verändert werden sollte?

Wie hat es denn mit dem Link zu meiner Dl in der PM ausgesehen, die ich dir geschickt habe? Hattest du denn das Vollbild sehen können, wenn du einen Mausklick auf das Vorschaubild machst?

MfG
MDuss

Benutzeravatar
oxpus
Chief handy-man
Beiträge: 2391
Registriert: Do 13. Dez 2007, 23:06
Wohnort: Irgendwo im I-Net
Kontaktdaten:

Re: Vollbild eines Downloadvorschaubildes wird nicht mehr angezeigt.

Beitrag von oxpus » So 14. Mai 2017, 14:57

Nein, geändert ist daran definitiv nichts.
Vielleicht klappt aber auch die Unterordnen Funktion für die Thumbs, die du manuell eingestellt hast, nicht fehlerfrei.
Vorgesehen ist das so jedenfalls nicht.
Karsten Ude

Kein Support zu unaufgeforderten PN's, Email oder via Messenger!

MDuss
Beiträge: 92
Registriert: So 30. Dez 2012, 10:26

Re: Vollbild eines Downloadvorschaubildes wird nicht mehr angezeigt.

Beitrag von MDuss » So 14. Mai 2017, 15:14

Hmmm.

Also das wäre echt dumm, wenn diese Unterordnen Funktion nicht mehr gehen würde.
Bisher hatte sie gut Funktioniert, und es war eigentlich echt super gewesen.

Kann man eigentlich Probeweise irgendwie ein Downgrade machen, also von 7.2.5 zurück auf 7.2.3?
Dann könnte ich nochmals dort nachsehen, ob es dort wieder laufen würde und dann wieder nach und nach auf die aktuelle Version gehen.

Denn wie gesagt. Ich habe so viele Vorschaubilder, wenn ich diese so einbinden würde direkt im thumbs Ordner, dann würde ich rein gar nichts mehr finden.

In meinem Testforum habe ich aber ein Testdownload, wo ich das Bild "Regelkonform eingebunden habe.
Das Bild liegt direkt im "thumbs" Ordner.
Und so ist es auch in der Datenbank eingetragen, also nur Bildname.jpg.
Das Bild wird auch verkleinert beim Download angezeigt. Wenn ich aber mit der Maus über das Bild fahre, kann ich mit einem Klick nicht das Vollbild anzeigen lassen.
Wie gesagt, das Bild hier ist Regelkonform.

Also liegt es an etwas anderem.

Wenn du willst, kann ich dir Login Daten zum Testforum und der zugehörigen Datenbank geben und du kannst es dir live ansehen.


MfG
MDuss

Benutzeravatar
oxpus
Chief handy-man
Beiträge: 2391
Registriert: Do 13. Dez 2007, 23:06
Wohnort: Irgendwo im I-Net
Kontaktdaten:

Re: Vollbild eines Downloadvorschaubildes wird nicht mehr angezeigt.

Beitrag von oxpus » So 14. Mai 2017, 17:18

So, wie gesagt, die Funktion hatte sich nicht geändert, ist sogar seit Version 7.0.x (damals noch mit Lytebox) gleich gewesen.
Was allerdings nun komplett missachtet wurde sind Single-Thumbnails, also wenn nur das Thumb des Downloads selber angezeigt werden soll.
Das wurde bislang nicht "gezählt" und damit auch das Popup nicht aktiviert.
Jetzt geht aber auch das wieder mit Version 7.2.6.
Karsten Ude

Kein Support zu unaufgeforderten PN's, Email oder via Messenger!

MDuss
Beiträge: 92
Registriert: So 30. Dez 2012, 10:26

Re: Vollbild eines Downloadvorschaubildes wird nicht mehr angezeigt.

Beitrag von MDuss » So 14. Mai 2017, 19:07

Hi oxpus.

Vielen Dank.
Jetzt funktioniert alles wieder normal.

MfG
MDuss

Antworten